The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

Portal:Tumbleweed/Tópicos

Ir para: navegação, pesquisa
Icon-info.png

Quem deve experimentar a Tumbleweed?

Qualquer usuário que deseje ter pacotes mais novos que os disponíveis nos repositórios openSUSE Leap. Isto inclui, mas não está limitado a, um kernel Linux atualizado, SAMBA, git, desktops, aplicativos de escritório e muitos outros pacotes.

Além disso, o Tumbleweed deve apelar mais para Power Users, Software Developers (que requerem as últimas pilhas de software e IDEs) e openSUSE Contributors (que precisam de uma plataforma confiável que seja o mais próxima possível openSUSE Factory enquanto permanecer utilizável).

Devido ao kernel Linux ser atualizado muito freqüentemente, os usuários que dependem de módulos de drivers de kernel de terceiros, incluindo drivers gráficos, não devem usar a distribuição Tumbleweed a menos que estejam familiarizados com a atualização desses drivers a partir da fonte por conta própria ou que tenham hardware suportado. Para mais detalhes, consulte a seção "Drivers de Terceiros" abaixo.

Note que os repositórios adicionais de Packman] estão disponíveis para o Tumbleweed!


Icon-info.png

Quem deve usar o openSUSE Leap em vez do Tumbleweed?

Embora todo esforço seja feito para construí-los, neste ponto não há garantia de ter todos os módulos adicionais disponíveis no openSUSE Tumbleweed como, por exemplo, VMware ou VirtualBox. E enquanto o repositório Packman Tumbleweed Essential tenta entregá-los, não há garantia de que eles sempre terão sucesso devido às incompatibilidades com o rápido avanço do kernel Linux. Os problemas com drivers gráficos proprietários são similares e não há garantia de que funcionarão amanhã, mesmo que funcionem hoje. Se você não sabe como compilar seus próprios módulos de kernel adicionais e não deseja aprender ou ficar de olho no que está sendo atualizado, por favor, não use o Tumbleweed.


Icon-usage.png

Como experimentar o Tumbleweed?

Para começar com o Tumbleweed siga as Tumbleweed Installation Instructions].

Siga a lista de discussão opensuse-factory para ser notificado sobre atualizações. Novos snapshots são lançados com a mesma freqüência com que estão prontos e a GQ automática já passou. Isto pode ser tão freqüente quanto diariamente, mas às vezes também leva algumas semanas, quando mudanças maiores são integradas.


Icon-warning.png

Lançamento de rolling (contínuo) significa sem atualizações, apenas correções e atualizações urgentes.

Ao atualizar o Tumbleweed, você pode usar o YaST ou o applet de atualização do sistema da mesma forma que no Leap.

Para manter o Tumbleweed atualizado com o último instantâneo usando zypper, execute o seguinte comando como root (idealmente dentro de uma tela ou sessão de tmux):

zypper dup

Note que pode haver algumas sutilezas com atualizações, especialmente com repositórios múltiplos. Veja por exemplo discussão recente sobre o uso do zypper dup versus zypper up e prioridades do zypper dup.


Icon-info.png

Codecs Multimídia

Devido às questões de licenciamento, o openSUSE não pode incluir certos codecs multimídia, como o H.264. Sem estes codecs, vídeos de certos sites, arquivos de música, sons, etc., podem não ser reproduzidos. Felizmente, o repositório Packman fornece estes codecs (juntamente com muitas outras coisas) para o openSUSE. Mais detalhes sobre o Packman podem ser encontrados em additional package repositories.

Para adicionar o repositório Packman completo e instalar os codecs ausentes, você pode iniciar o gerenciador de repositórios YaST, clicar em "Add", selecionar "Community repositories" e verificar "Packman"; ou, no console, executar os seguintes comandos como root:

zypper ar -cfp 90 http://ftp.gwdg.de/pub/linux/misc/packman/suse/\
openSUSE_Tumbleweed/ packman
zypper dup --from packman --allow-vendor-change

Para adicionar apenas o repositório Packman Essentials (fornece codecs, aplicativos de áudio e reprodutores de vídeo) e instalar codecs ausentes, execute os seguintes comandos como root:

zypper ar -cfp 90 http://ftp.gwdg.de/pub/linux/misc/packman/suse/\
openSUSE_Tumbleweed/Essentials packman-essentials
zypper dup --from packman-essentials --allow-vendor-change

Após a instalação dos codecs da Packman, o teste Reprodutor de vídeo HTML5 do YouTube pode ser executado para ver se o H.264 está funcionando corretamente em um navegador.


Icon-warning.png

Drives de terceiros (proprietários)

Devido ao ritmo rápido das atualizações do kernel no Tumbleweed, os módulos de driver de kernel de terceiros podem não ser suficientemente rápidos para alcançar a última versão do kernel. No caso improvável de seu módulo de driver do kernel não funcionar no Tumbleweed, por favor, considere o uso do openSUSE Leap.

O driver proprietário NVidia’s geralmente funciona muito bem com o Tumbleweed.

Os drivers proprietários NVidia para GeForce série 400 e GPUs mais novas podem ser facilmente instalados no Tumbleweed usando os seguintes comandos como root:

zypper ar -f https://download.nvidia.com/opensuse/tumbleweed nvidia
zypper inr

Em casos extremamente raros, por exemplo, se você precisar de uma versão beta do driver, você também pode instalar manualmente o driver. Leia NVidia - The hard way para maiores detalhes. Lembre-se também de recompilar e reinstalar estes drivers de terceiros a cada atualização do kernel no Tumbleweed.

Alternativamente, o repositório dkms-nvidia do openSUSE Build Service pode ser usado. Este repositório fornece drivers NVIDIA que funcionam com dkms (os módulos da NVIDIA serão recompilados automaticamente para cada nova atualização do kernel). Ele também contém uma variedade de versões de drivers NVIDIA para uso com placas que não são suportadas com ou não se comportam bem com os drivers mais recentes. Para fazer uso deste repositório, simplesmente clique no link 1 Clique em Instalar para a versão do driver que você deseja instalar aqui ou execute os seguintes comandos como root para o último driver NVIDIA do dkms-nvidia:

zypper ar -f https://download.opensuse.org/\
repositories/home:/Bumblebee-Project:/nVidia:/latest/\
openSUSE_Tumbleweed/home:Bumblebee-Project:nVidia:latest.repo
zypper in dkms-nvidia

Observe que o repositório dkms-nvidia não é "oficialmente apoiado" e qualquer pessoa que deseje usá-lo provavelmente estará por conta própria para solucionar problemas.

Quanto ao AMD, AMDGPU-PRO não é suportado para o Tumbleweed. O Tumbleweed vem com um driver Radeon instalado fora da caixa (out of the box) que, de qualquer forma, é normalmente a melhor escolha.


Icon-user.png

Como posso contribuir?

  • Você pode testar a distribuição de Tumbleweed e dar feedback, compartilhar experiências e participar das discussões de desenvolvimento. Para isso, envie seu correio para o endereço da lista, opensuse-factory@opensuse.org.
  • Se você encontrar problemas com sua instância do Tumbleweed, você pode relatar problemas para openSUSE bugzilla.
  • Se você for um empacotador, você pode enviar novos pacotes para o projeto openSUSE:Factory.