Repositórios do GNOME

Ir para: navegação, pesquisa
Este artigo contém informação sobre como adicionar os repositórios GNOME.
Esta página usa $current para identificar a versão mais recente e atual do openSUSE. Utilizávamos a versão do openSUSE 11.1, no momento em que este documento foi publicado.

GNOME:Factory (G:F)

O link abaixo é onde a última versão compilada do GNOME está.

http://download.opensuse.org/repositories/GNOME:/Factory/

  • fornecemos pacotes para ambas versôes: Factory e $current.
  • Isto significa que, quando acessas este repositório, podes atualizar o seu GNOME para um GNOME mais novo do que aquele que foi lançado com a $current.
  • Habilitando este repositório, deves utilizar 'zypper dup' na linha de comando para receber o seu GNOME atualizado.

GNOME:Contrib (G:C)

No link abaixo, é onde os pacotes para o Contrib (i.e., o repositório oficial para pacotes adicionais do openSUSE) são desenvolvidos. Contém a última versão de muitos aplicativos.

http://download.opensuse.org/repositories/GNOME:/Contrib/

  • Fornecemos pacotes para ambas versões: Factory e $current.

GNOME:Backports:x.yy (G:B:x.yy) (onde x.yy = versão do GNOME, ou Factory)

Pacotes atualizados e necessários para compilar e instalar o GNOME a partir da G:S:x.yy ou da G:F sobre a $current.

http://download.opensuse.org/repositories/GNOME:/Backports:/

  • Se um pacote da $current é demasiadamente antigo para construir o GNOME em oposição a ele, pacotes atualizados serão colocados aqui. Além disso, se um pacote GNOME novo da G:F não é adequado para instalação na $current, a versão apropriada do pacote será colocada aqui.
    • Por exemplo, com o GNOME 2.26, há uma nova versão do pacote gnome-power-manager'. Esta nova versão requer DeviceKit e DeviceKit-power (que são dois novos pacotes). Estes pacotes, por sua vez requerem uma nova versão do udev. Uma vez que não pretendemos atualizar os componentes de base crítica, quando evitável. Portanto, enquanto o GNOME foi atualizado para a versão 2.26, gnome-power-manager permanecerá na versão 2.24.
  • Deves habilitar este repositório conjuntamente com G:S:.x.yy ou G:F e então utilizar 'zypper dup' para obter todas as suas atualizações adequadamente.

GNOME:Estável:x.yy (G:S:x.yy, onde x.yy = versão do GNOME)

Este é o lugar onde o GNOME $current é armazenado. (A versão do GNOME que é fornecida com a $current).

http://download.opensuse.org/repositories/GNOME:/STABLE:/

  • Atualizações upstream para a $current GNOME são enviadas para este repositóorio.
  • Pacotes da G:B também serão copiados para este repositório uma vez que a versão Factory seja lançada como a nova versão do openSUSE.
  • Se tudo o que queres é a última atualização para a $current GNOME, não precisas habilitar a G:F ou a G:B.
  • Se habilitada, necessitarás utilizar 'zypper up' na linha de comando.

GNOME:INSTÁVEL (G:U)

Quando o openSUSE está em estágio posterior a beta/RC, a GNOME:Factory é congelada e não são permitidos novos pacotes de atualizações na G:F.

http://download.opensuse.org/repositories/GNOME:/UNSTABLE/

  • Atualizaremos o GNOME para a próxima versão neste repositório enquanto a Factory estiver congelada.
  • Quando a Factory é reaberta para atualizações novamente, todos os pacotes dle atualizações em G:U são incorporados à versão G:F em preparação para o próximo lançamento do openSUSE.
  • O Se habilitado, necessitarás utilizar 'zypper dup' na linha de comando.

GNOME:Apps

O GNOME:Apps é um repositório popular para aplicações do GNOME que não segue o ciclo de lançamento do GNOME, como o GIMP, o Inkscape e o Pidgin. Este é um lugar para desenvolver pacotes destinados à versão Factory.

Além disso, projetos upstream do GNOME podem manter os seus próprios respositórios, destinados aos aplicativos desses projetos. Por exemplo, embora o Tomboy seja parte do GNOME e esteja disponível em todos os repositórios padrão do GNOME, o projeto Tomboy disponibiliza seus últimos lançamentos estáveis no GNOME:Apps:Tomboy, e seus últimos lançamentos em desenvolvimento no GNOME:Apps:Tomboy:Unstable. Estes repositórios por aplicativo permitem que você atualize aplicativos individuais do GNOME sem ter que adicionar grandes repositórios que oferecem atualizações dos GNOME inteiro. A lista dos repositórios é mantida em GNOME/Repositories/Apps.