FAQ

Ir para: navegação, pesquisa
Tem perguntas ou soluções para estes assuntos relacionados com o openSUSE? Por favor, sinta-se livre para sadicioná-las a este FAQ!

Instalando o openSUSE

Quais são os diferentes métodos de instalação?

Veja em Downloads e em Comprar o openSUSE.


openSUSE e Software

Repositórios

Onde estão os repositórios de pacotes?

Para utilizar os repositórios de pacotes padrão, veja em Repositórios de pacotes. Para informação ou repositórios adicionais, veja em Repositórios adicionais de pacotes, ou utilize o módulo Repositórios de software no YaST (teclando na sequencia: Lançador de aplicativos>Computador>YaST, após digite a senha de administrador e clique em "OK" ou pressione "Enter"; na janela do YaST escolha "Repositórios de software" à direita).

Que outras fontes de pacotes posso habilitar el adicionar?

Além dos repositórios on-line do openSUSE, você pode considerar adicionar o repositório Packman. Para mais informação sobre ele e um rápido guia, veja os repositórios em openSUSE-Community.org.

"Uma transação ZYpp já está em progresso"

Se se deparar com este erro a qualquer momento, certifique-se de que todos os programas que possam estar utilizando o sistema de gerenciamento de pacotes tenham sido fechados. Isto inclui o Zypper, o módulo gerenciador de pacotes YaST e qualquer aplicativo acessando a base de dados RPM. Se você estiver certo de que nenhum destes está sendo executado, então algum deles pode estar funcionando mal. Para matar o processo ofensivo, execute:

su -c "kill -9 $(lsof -t /usr/lib/libzypp*)"


Isto funcionará se for o zypper, mas o YaST pode estar executando e amarrando o bloqueio, e não mostrará lsof. Em vez disso, tente olhar para a mesma coisa que o zypper está olhando quando ele dá a você o erro:

cat /var/run/zypp.pid


Onde, /var/run/zypp.pid é o arquivo de bloqueio para o zypper. Se existe, contém o pid do processo que mantém o bloqueio. Utilize ps para verificar para que o programa está assim:

ps 'cat /var/run/zypp.pid'


Em seguida, mate-o se faz sentido fazê-lo. Se, como é possível, o processo não existe, então:

su rm /var/run/zypp.pid


consertará o problema.

Por que não há suporte disponível para MPEG-4/criptografado, DVDs/Quicktime, e outros?

Restrições legais impedem vários pacotes e formatos, que os usuários do openSUSE pedem frequentemente para ser incluídos no openSUSE, de serem distribuídos. Veja a página formatos restritos para informações mais específicas.

= Atualização para o mais recente KDE

O openSUSE disponibiliza sempre a última versão do KDE, caso o queira. Existe um fantástico guia para esta configuração em KDE/Upgrade.

Os pacotes X, Y, Z estão disponíveis em algum lugar? Como posso procurar por pacotes?

A vasta maioria dos pacotes estão disponíveis nos repositórios recomendados. Entretanto, existem centenas de outros pacotes disponíveis através do Serviço de Compilação também. Existe, ainda, uma pesquisa de pacotes que buscará nos repositórios padrão on-line, Packman, assim como no Serviço de Compilação, em:pacotes da Comunidade openSUSE.

Gerenciador composto (Compiz/Compiz-Fusion)

Posso ter o Compiz executando no openSUSE?

Com certeza. O Compiz está disponível no Serviço de Compilação. Plugins e ferramentas de configuração estão no Compiz-Fusion. Recentes lançamentos do Compiz podem ser encontrados nos repositórios do Serviço de Compilação. Existe uma guia sobre a configuração e mais informações disponíveis a respeito deste aplicativo em Compiz.

Se você usa KDE 4, você deve usar o gerenciador composto nativo KWin.


Hardware

Posso encontrar uma lista de hardware compatível por aí?

Existe uma bela lista de compatibilidade de hardware disponível. Esta lista com certeza não é exaustiva, mas contém bastantes informações que podem ser úteis.

How can I get my piece of hardware to work?

You may wish to search for your hardware model or type of hardware in the openSUSE Wiki and see if any information can be found.

Drivers para Placas Gráficas

Como obtenho os drivers binários para ATI/Nvidia atualizados e executando?

Veja Nvidia e ATI.

Sem fios

Existe uma lista de placas wireless suportadas disponível?

Certamente, dê uma olhada em http://linux-wless.passys.nl/

Todas as placas, com uma marca verde, possuem drivers nativos para Linux. A maioria delas pode ser compilada no kernel SUSE manualmente, mas algumas, tais como as baseadas em chipset Atheros e acx100, apenas precisam que sejam instalados alguns poucos RPMs. Verifique num repositório non-OSS para encontrar os RPMs, se houver.

Como posso fazer a minha placa sem fios trabalhar?

Quando os drivers proprietários Linux forem disponibilizados pelos fabricantes, existe uma hipótese considerável de que uma placa sem fios mais antiga funcione imediatamente depois de ser configurada no YaST. Para novas placas sem fios, se o driver proprietário for Linux, então o openSUSE pode precisar de drivers adicionais (tal como o driver Atheros madwifi), seguido da comfiguração da placa/driver com o YaST.

Para placas sem fio onde o driver nativo Linux não está disponível, poderá ser necessário usar o Ndiswrapper.

Webcams

Como posso instalar a minha webcam?

Olhe para o artigo web câmeras para configurar sua webcam.


Comunicar

Minha questão não foi respondida aqui ou necessito de mais ajuda.

Tente no Portal:Suporte disponível também através de qualquer página pelo link Suporte à esquerda na seção Navegação.

Junte-se a nós! Veja a página openSUSE:Canais de comunicação.


AppArmor

O que é o AppArmor?

Novell AppArmor é um aplicativo de segurança do sistema Linux, efetivo e fácil de usar, que protege o seu sistema operacional Linux e aplicativos dos efeitos de ataques, vírus e aplicativos maliciosos. O AppArmor não é um firewall ou um aplicativo detector de vírus - mas sim uma completa prevenção contra intrusões ao sistema.

Como ele se compara com o SELinux?

O SELinux implementa segurança rotulada, que aplica uma etiqueta identificando o nível de segurança adequado para cada arquivo de dados. Embora esse recurso seja valorizado por agências de inteligência, apresenta um significativo nível de complexidade e sua aplicabilidade para a empresas comerciais é limitada. Assim, embora ambos AppArmor e SELinux trabalhem para o mesmo objetivo, o AppArmor é muito mais fácil de implementar e manter:
  • O AppArmor inclui uma automação totalmente baseada no conjunto de ferramentas do YaST para desenvolver uma política de segurança. Em contraste, o método do SELinux para criar e modificar a política de um programa é principalmente baseado em texto e requer muitos passos, e envolve uma quantidade significativa de configurações e intervenções manuais.
  • A solução do AppArmor é extremamente auditável - as políticas do AppArmor são humanamente legíveis e de fácil compreensão.
  • Nenhum conhecimento especializado é necessário, ao contrário do SELinux. Praticamente qualquer pessoa pode usar as ferramentas do AppArmor para configurar um sistema e protegê-lo contra softwares maliciosos.
  • Os aplicativos não têm de ser modificados em tudo para serem protegidos pelo AppArmor. Entretanto, para obter todo o poder do SELinux, os aplicativos devem ser recompilados e ligados com as bibliotecas do SELinux.

Existe alguma documentação disponível a respeito do AppArmor?

Veja a página do AppArmor neste wiki.

Links esternos