Home Wiki > SDB:ATI drivers
Sign up | Login

SDB:ATI drivers

tagline: Da openSUSE


Icon-cleanup.png Este artigo necessita de atenção, pois não observa as nossas orientações do wiki.
Se você quer colaborar, por favor familiarize-se com elas. Se você tem quaisquer dúvidas,
não hesite em nos contatar. Estamos mais do que dispostos a ajudá-lo!
Este guia pretende ajudá-lo a instalar os drivers proprietários AMD (fglrx).
Pois eles não podem ser integrados à distribuição openSUSE em virtude de não estarem licenciados como Software Livre e de Código Aberto.
Versão: 11.2+This applies to openSUSE starting from 11.2.
Atenção! O atual Catalyst (11.2) não funciona com o Kernel 2.6.38 (a menos que seja corrigido, para saber como veja aqui).

AMD portal editar

AMD Hardware

Drivers de Fonte Aberto

Drivers proprietários

  • Fglrx


Hardware suportado

O fglrx não funciona com placas abaixo da Radeon HD série 2000. O Catalyst 11,2 suporta os seguintes GPU's. Mobile variantes destas também funcionarão.

R600        Radeon HD 2900
RV610/RV630 Radeon HD 2400/2600, M71, M72, M74, M76
RV620       Radeon HD 3450/3470, M82  
RV635       Radeon HD 3650/3670, M86
RV670       Radeon HD 3850/3870, M88
RS780       Radeon HD 3100/3200/3300
RS880       Radeon HD 4100/4200/4290
RV710       Radeon HD 4350/4550, M92
RV730       Radeon HD 4650/4670, M96
RV770       Radeon HD 4850/4870, M97, M98
CEDAR       Radeon HD 5450
REDWOOD     Radeon HD 5550/5570/5670
JUNIPER     Radeon HD 5730/5750/5770
CYPRESS     Radeon HD 5830/5850/5870
HEMLOCK     Radeon HD 5970
PALM        Radeon HD 6310/6250 
BARTS       Radeon HD 6850/6870
CAICOS      Radeon HD 6350
TURKS       Radeon HD 6670

O Método Fácil (GUI)

Através do YaST

  • Adicione o repositório que corresponde a sua distrisbuição através do módulo de Repositórios de Software do YaST.
    • Siga o caminho: Lançador de aplicativos > Computador e clique em YaST ou arraste o ícone do YaST para a pasta da área de trabalho e copie-o ali.
    • Clique em Repositórios de Software no Centro de Controle do YaST.
    • Clique em Adicionar, selecione Especificar URL e clique em Próximo.
    • Digite o URL, escolha o nome para o repositório e clique em OK.
  • Instale o pacote 'fglrx correspondente a arquitetura do seu equipamento, através dos seguintes passos:
    • No Centro de Controle do YaST, clique em Gerenciamento de Software.
    • Procure por "fglrx" e verifique os pacotes que correspondem à arquitetura da sua distribuição.
    • Clique em Aceitar para confirmar sua escolha.

O método simples para efetivar as alterações é reiniciar o sistema.


1-click install

Atenção! Através do instalador um clique obters-s-á um driver inferior ao instalado através do método YaST acima. No entanto, usuários menos experientes podem ainda achar que é melhor.

1-click installation of ATI/AMD drivers

  • O pacotes oficiais instalados pelo instalador 1-click, entretanto, podem causar problemas. Depois, você poderá executar o seguinte como root,
# aticonfig --initial
  • Após fazer isto, reinicie o sistema.

O Método Fácil (CLI)

Através do zypper

  • Adicione o repositório ATI (substitua 11.4 pelo número da sua versão):
# zypper ar -f http://linux.ioda.net/mirror/ati/openSUSE_11.4/ fglrx
  • Instale o fglrx (faça um ou outro, não ambos; substitua "114" pelo número da sua versão):

Instale este pacote se você usa o openSUSE 64-bit

# zypper in fglrx64_xpic_SUSE114

ou, Instale este pacote se você usa o openSUSE 32-bit

# zypper in fglrx_xpic_SUSE114    
  • Reinicie o sistema para ativar o driver.

Compilando o FGLRX Manualmente

O driver ATI também pode ser obtido através do website da AMD.

A não ser que o mantenedor do repositório não oficial pare de fornecer atualizações, esse método produzirá pacotes idênticos aos do repositório não oficial.
  • Baixe os mais recentes drivers ATI através da página de suporte da AMD.
  • Num console, faça o seguinte:
  • Mude para o usuário root,
su 
  • Vá para o diretório onde está o driver da ATI e execute o instalador,
sh ./ati-driver-installer-11-4-x86.x86_64.run --buildpkg SuSE/SUSE-autodetection
  • Instale o pacote gerado,
zypper in fglrx* 

(você necessitará instalar: kernel-source, kernel-devel, kernel-default-devel, kernel-desktop-devel para instalar o rpm gerado.)

  • Crie arquivos de configuração inicial (isto já pode ser feito automaticamente pelo pacote),
aticonfig --initial 
  • Reinicie o sistema.
shutdown -r now

Veja também

Artigos relacionados